PHP API Client documentation

#PHP developer, you are?

We have a client for you!

The PHP client facilitates the usage of the REST API in your PHP projects when building extensions and/or tools for your favorite PIM.

There are several versions of these clients:

  • The version v1.0 is compatible with the PIM 2.0.
  • The version v2.0 is compatible with the PIM 2.1 and 2.2.
  • The version v3.0 is compatible with the PIM 2.3.
  • The version v4.0 is compatible with the PIM 3.0 and 3.1.
  • The version v5.0 is compatible with the PIM 3.2 and 4.0.
  • The version v6.0 is compatible with the PIM 5.0.
  • The current next and latest versions are compatible with the PIM 6.0 and the SaaS versions.

#Support & issues

Please be aware that the PHP client is only supported in best effort, whether you are an Enterprise or Community customer.

If you ever find a bug, do not hesitate to directly open a Github issue on the API client repository.

Don't forget that we also love when you contribute and help us do better tools. So do not hesitate! Every feedback/pull request is very welcomed!

#Keep in touch

If you just want to discuss about it, join the community in the #web-api channel in our Slack user group community.